Graql shell not starting


I am trying to launch the graql shell but its not starting. I get either of below two errors:

Error 1: > 2017-05-18 09:27:08.339:WARN:oejwc.Parser:WebSocketClient@1589683045-17‌​: org.eclipse.jetty.websocket.api.MessageTooLargeException: Text message size [695635] exceeds maximum size [65536]

Error 2:

Exception in thread “graql-session-0” java.util.ConcurrentModificationException
at java.util.HashMap$HashIterator.nextNode(
at java.util.HashMap$
at ai.grakn.graph.internal.AbstractGraknGraph.loadOntologyCacheIntoTransactionCache(
at ai.grakn.graph.internal.AbstractGraknGraph.getConceptLog(
at ai.grakn.graph.internal.AbstractGraknGraph.buildType(
at ai.grakn.graph.internal.AbstractGraknGraph.getTypeByLabel(
at ai.grakn.graph.internal.AbstractGraknGraph.getMetaConcept(
at ai.grakn.engine.session.GraqlSession.getTypes(
at ai.grakn.engine.session.GraqlSession.sendTypes(
at ai.grakn.engine.session.GraqlSession.lambda$new$48(
at java.util.concurrent.ThreadPoolExecutor.runWorker(
at java.util.concurrent.ThreadPoolExecutor$

I am using grakn 0.12.1 and am running it on CentOS Virtual machine(4050 base memory, 2 Processors)


You’re unlucky enough to be encountering two separate bugs here! There was an issue accessing the graph when starting the shell. The server has attempted to alert the client, but the error message is too large to send. I’ve logged both these bugs and we’ll try and fix them in the next few weeks.

It looks like the bug is caused because something else is trying to access your graph. Maybe try running stop and start and then re-launching the shell?


I tried stop and start multiple times but the same error (mostly the MessageTooLargeException) comes every time.