Java Problems on setup


#1

hi,
I am trying to install grakn on macOS and running into java issues. Any help is welcome.

The system has the following Java Version installed.

java version “11.0.1” 2018-10-16 LTS
Java™ SE Runtime Environment 18.9 (build 11.0.1+13-LTS)
Java HotSpot™ 64-Bit Server VM 18.9 (build 11.0.1+13-LTS, mixed mode)

When I start the grakn server (grakn server start) - I get the following error 

An error has occurred during boot-up. Please run ‘grakn server status’ or check the logs located under the ‘logs’ directory.Unsupported Java version [11] found. Grakn needs Java 1.8 in order to run.

I am unsure what java version I will need to install. I have the latest java version. Do I need to roll back to get to 1.8 (is it jre-8u65 or something).

Thanks


#2

Yes, as the error message says, you will need Java 1.8