Node client | grakn/grpc issue


#1

Having a difficult time with the node js client to grakn, here is the error message |

warning in ./node_modules/grakn/node_modules/grpc/node_modules/node-pre-gyp/lib/util/versioning.js

17:20-67 Critical dependency: the request of a dependency is an expression

warning in ./node_modules/grakn/node_modules/grpc/node_modules/node-pre-gyp/lib/pre-binding.js

20:22-48 Critical dependency: the request of a dependency is an expression

warning in ./node_modules/grakn/node_modules/grpc/src/grpc_extension.js

32:12-33 Critical dependency: the request of a dependency is an expression

There seems to be an issue regarding the build of the grakn package and a conflict with grpc versioning, unfortunately it presents itself in a non-linear fashion. I would be grateful if the grakn engineers have some insight into this.


#2

Hi @angus,

what’s your use case?

Please report steps necessary to reproduce the issue