not able to start grakn on unix


#1

I have installed grakn on unix and earlier it was working fine but now giving issues as it is not able to start.

I tried to run it using below command: ./grakn server start

Getting below error. Starting Storage-FAILED! Unable to start Storage Please run ‘grakn server status’ or check the logs located under ‘logs’ directory.


#2

Hi @chan1305,

make sure to stop any other older running instances of Grakn on your system before trying to start this new version.

If the starting process keep failing please run grakn server status and check the cassandra log located in /logs/cassandra.log folder. Is there something useful printed in there?

Please try to follow the steps outlined here to report booting issues.

Marco


#3

@chan1305 another possible issue is that you did not set the JAVA_HOME environment variable correctly, which happened to me.


#4

I ran into the same issue… turned out it was because Java couldn’t allocate ~3.8GB of memory. (There was an “hs_err_####.log” file in the Grakn root folder explaining this.) When I freed up some memory, it started without problem.