Start grakn server with error: couldn't get PID of Grakn. Received '


#1

After run ./grakn server start, the terminal show Storage and Queue Start success. But the Grakn failed to start.
The error message is “Couldn’t get PID of Grakn. Received '”.

  1. Grakn version 1.0.0
  2. OS: Ubuntu 14.04
  3. I tried download zip package, also tried compile from source code. The result is same.
  4. Follow Setup Guide in documentation.
  5. Current status:
    Queue and Storage pid files found in /tmp folder;

redis server run on port 6379;

jps shows Master, Secondary NameNode, CassandraDaemon, CommunityEntryPoint, ResourceManager, NameNode, NodeManager, DataNode;

grakn.log
java.lang.RuntimeException: Couldn’t get PID of Grakn. Received ''
at ai.grakn.bootup.PidRetriever.getPid(PidRetrieve.java:39)
at ai.grakn.engine.Grakn.newPidFile_deleteOnExit(Grakn.java:57)
at ai.grakn.engine.Grakn.main(Grakn.java:45)

and, casssandra.log is ok, other log is empty.


Please report any error "java.lang.RuntimeException: Couldn’t get PID of Grakn. Received '"
#2

After debugging, found the root cause. The Grakn process startup command line’s java classpath is too long that exceeds the max length of CMD column of the “ps -ef | grep …” result.


#3

Experiencing the same problem.
Running Grakn 1.0.0 on Ubuntu 14.04.
How did you solve it?


#4

Thank you for notifying us of this problem. We’ll look at the issue and provide a bugfix in the upcoming version.

@kasper Have you ever noticed this issue on your Ubuntu machine?


#5

Change PID retrieving method from “ps + grep” to java method in the UnixGraknPidRetriever.java of grakn-bootup project. .
And, when build from the latest code, you may encounter missing dashboard.js while using visualizer. Copy one from 1.0.0 distruibution package solve it.


#6

Hi, there, I have been stuck by the same issue for a while. Can you be so good to explain in more detail that how you resolved it.


#7

@vystar it’ll be great if you can share your solutions with us here, as we’ve been having difficulties reproducing the issue you’ve experienced on a Ubuntu machine.