Starting Grakn... FAILED! [0.17.1][RESOLVED]


#1

Hi all!

I’m new to Grakn. Just downloaded the 0.17.1 zip file from the setup guide page and tried to run ./grakn server start on a CentOS7 server with jdk1.8.0_91.

Here’s the output :

Starting storage... SUCCESS
Starting Queue... SUCCESS
Starting Grakn.................... FAILED!

The only log file in ./log is cassandra.log, without any ERROR line.

Does anyone have any idea ?

Thanks,
Gunther


#2

Hi Gunther,

Sorry you’re having trouble so early in the process!

Can you give me the output of the following commands from within the Grakn directory?

./grakn server status
jps
ps -ef | grep redis-server
netstat -ntlp
ls -l

Do the contents of /tmp/grakn-queue.log show any errors?


#3
./grakn server status
=============================================================================
      ________  _____     _______  __    __  __    __      _______  ___
     |   __   ||   _  \  |   _   ||  |  /  /|  \  |  |    |   _   ||   |
     |  |  |__||  | |  | |  | |  ||  | /  / |   \ |  |    |  | |  ||   |
     |  | ____ |  |_| /  |  |_|  ||  |/  /  |    \|  |    |  |_|  ||   |
     |  ||_   ||   _  \  |   _   ||   _  \  |   _    |    |   _   ||   |
     |  |__|  ||  | \  \ |  | |  ||  | \  \ |  | \   | __ |  | |  ||   |
     |________||__|  \__\|__| |__||__|  \__\|__|  \__||__||__| |__||___|

                          Grakn: The Database For AI
=============================================================================

Storage: RUNNING
Queue: RUNNING
Grakn: NOT RUNNING

#4
/opt/jdk1.8.0/bin/jps
8833 Bootstrap
27796 Jps
21766 CassandraDaemon
8967 Bootstrap

#5
ps -ef | grep redis-server
root     10386     1  0 14:41 ?        00:00:02 ./services/redis/redis-server-linux 127.0.0.1:6379
root     17506 29218  0 15:10 pts/0    00:00:00 grep --color=auto redis-server

#6
netstat -ntlp
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 127.0.0.1:6379          0.0.0.0:*               LISTEN      10386/./services/re
tcp        0      0 127.0.0.1:37643         0.0.0.0:*               LISTEN      10008/java
tcp        0      0 0.0.0.0:33839           0.0.0.0:*               LISTEN      8967/java
tcp        0      0 0.0.0.0:111             0.0.0.0:*               LISTEN      1/systemd
tcp        0      0 127.0.0.1:9042          0.0.0.0:*               LISTEN      10008/java
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      1055/sshd
tcp        0      0 127.0.0.1:3030          0.0.0.0:*               LISTEN      731/ruby
tcp        0      0 127.0.0.1:3031          0.0.0.0:*               LISTEN      731/ruby
tcp        0      0 127.0.0.1:7000          0.0.0.0:*               LISTEN      10008/java
tcp        0      0 127.0.0.1:25            0.0.0.0:*               LISTEN      1308/master
tcp        0      0 0.0.0.0:6010            0.0.0.0:*               LISTEN      29126/sshd: ********
tcp        0      0 0.0.0.0:9501            0.0.0.0:*               LISTEN      8967/java
tcp        0      0 129.20.128.82:2525      0.0.0.0:*               LISTEN      1401/********_daemon
tcp        0      0 0.0.0.0:9502            0.0.0.0:*               LISTEN      8833/java
tcp        0      0 127.0.0.1:7199          0.0.0.0:*               LISTEN      10008/java
tcp        0      0 0.0.0.0:8801            0.0.0.0:*               LISTEN      8967/java
tcp        0      0 0.0.0.0:9601            0.0.0.0:*               LISTEN      8967/java
tcp        0      0 0.0.0.0:8802            0.0.0.0:*               LISTEN      8833/java
tcp        0      0 0.0.0.0:9602            0.0.0.0:*               LISTEN      8833/java
tcp        0      0 0.0.0.0:36805           0.0.0.0:*               LISTEN      8833/java
tcp        0      0 0.0.0.0:37990           0.0.0.0:*               LISTEN      8833/java
tcp        0      0 0.0.0.0:43430           0.0.0.0:*               LISTEN      8967/java
tcp        0      0 127.0.0.1:9160          0.0.0.0:*               LISTEN      10008/java
tcp        0      0 127.0.0.1:9001          0.0.0.0:*               LISTEN      8967/java
tcp        0      0 127.0.0.1:9002          0.0.0.0:*               LISTEN      8833/java
tcp6       0      0 :::22                   :::*                    LISTEN      1055/sshd
tcp6       0      0 :::6010                 :::*                    LISTEN      29126/sshd: ********

#7
ls -l
total 84
drwxr-xr-x  2 root root  4096 Nov 10 15:32 conf
drwxr-xr-x  4 root root  4096 Nov 23 11:51 db
drwxr-xr-x 15 root root  4096 Nov 22 17:41 examples
-rwxr-xr-x  1 root root 16400 Nov 10 15:25 grakn
-rwxr-xr-x  1 root root  3361 Nov 10 15:25 graql
-rw-r--r--  1 root root 35147 Nov 10 15:25 LICENSE.txt
drwxr-xr-x  2 root root  4096 Nov 23 11:59 logs
-rw-r--r--  1 root root  3159 Nov 10 15:25 README.md
drwxr-xr-x  7 root root  4096 Nov 22 17:20 services

#8

grep ERROR /tmp/grakn-queue.log

Nothing returned.


#9

Here’s the content of file /tmp/grakn-queue.log :

22135:M 23 Nov 15:30:54.534 * Increased maximum number of open files to 10032 (it was originally set to 1024).

Redis 3.2.9 (00000000/0) 64 bit
Running in standalone mode
Port: 6379
PID: 22135
http://redis.io

22135:M 23 Nov 15:30:54.535 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
22135:M 23 Nov 15:30:54.535 # Server started, Redis version 3.2.9
22135:M 23 Nov 15:30:54.536 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot
or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
22135:M 23 Nov 15:30:54.536 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command 'ech
o never > /sys/kernel/mm/transparent_hugepage/enabled' as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
22135:M 23 Nov 15:30:54.539 * DB saved on disk
22135:M 23 Nov 15:30:54.541 * DB saved on disk
22135:M 23 Nov 15:30:54.543 * DB saved on disk
22135:M 23 Nov 15:30:54.543 * DB loaded from append only file: 0.007 seconds
22135:M 23 Nov 15:30:54.543 * The server is now ready to accept connections on port 6379

#10

Found a WARN among all INFO lines in ./logs/cassandra.log :

grep WARN logs/cassandra.log
WARN  [main] 2017-11-23 15:30:46,183 CassandraDaemon.java:85 - JMX is not enabled to receive remote connections. Please see cassandra-env.sh for more info.

#11

Nothing seems out of the ordinary so far. You can try running Grakn manually with this command to see what went wrong:

java -cp "./services/lib/*" -Dgrakn.dir="./services/" -Dgrakn.conf="../conf/grakn.properties" ai.grakn.engine.GraknEngineServer

Run this in the same directory that the grakn script is.


#12

This warning message is expected.


#13

Thanks @thanh, it seems to work fine now :

./grakn server status
=============================================================================
      ________  _____     _______  __    __  __    __      _______  ___
     |   __   ||   _  \  |   _   ||  |  /  /|  \  |  |    |   _   ||   |
     |  |  |__||  | |  | |  | |  ||  | /  / |   \ |  |    |  | |  ||   |
     |  | ____ |  |_| /  |  |_|  ||  |/  /  |    \|  |    |  |_|  ||   |
     |  ||_   ||   _  \  |   _   ||   _  \  |   _    |    |   _   ||   |
     |  |__|  ||  | \  \ |  | |  ||  | \  \ |  | \   | __ |  | |  ||   |
     |________||__|  \__\|__| |__||__|  \__\|__|  \__||__||__| |__||___|

                          Grakn: The Database For AI
=============================================================================

Storage: RUNNING
Queue: RUNNING
Grakn: RUNNING

#14

Great! Is there anything you did differently this time? Or did it magically start to work? :laughing:


#15

Here are the only 2 lines of WARN and ERROR from the log running Grakn manually :

WARN org.reflections.Reflections - given scan urls are empty. set urls in the configuration
ERROR spark.staticfiles.StaticFilesConfiguration - External Static resource location must be a folder

It seems to be your magical touch! :raised_hands: